Plugin Overview

HouseBot Email Sender Device Plugin Overview

The HouseBot Email Sender Device is a Software Device that can be used to send an email message. It can send a message to one or more email recipients. The Device requires an active internet connection for sending the messages.

This Device can be used to send notification messages to an email client or a cell phone. By using a HouseBot Task, the messages can be triggered by any Property Value change.

The subject and message body can be configured using Property Values to contain any message.

The Device sends messages using SMTP (simple mail transfer protocol).

See the Configuration section for more information on setting up the Email Sender Device.


Configuration

Configuring the Email Sender Device

To configure an Email Sender Device, first create a new Device.

  1. From the HouseBot main menu, select "File / New / Device...".
  2. The New Device Wizard will prompt you through the setup.
  3. Select the "No Hardware Interface Required" radio button.
  4. Select "Email Sender (SMTP)" as the type of Device.
  5. Give a unique and descriptive name to the Device.
  6. Enter the message to send, if known.
  7. Enter the recipients (email addresses), if known.
  8. Enter the message subject.
  9. Enter the address of the SMTP server to send the message through.
  10. Press OK.

Some of the Properties only need to be setup initially and are required. These Properties are highlighted in RED.

Property | Description
Message | This value contains the text of the message that will be sent.
Message Recipients | This value contains a semicolon delimited list of email addresses that the message will be sent to. The format of the email addresses must comply with standard email formatting.
Message Sender | Identifies the email address of the sender. This will be represented as the 'From' field in the received message. Most email servers require this value, but some do not. The sender name can be formatted to hide the full email address from the receiver by using greater-than/less-than symbols in the value such as "<Name to Display> email_address@domain.com"
Message Subject | This value contains the text of the subject of the message. This value can be left blank if no subject is needed.
Send Message | When set to Yes, the message will be sent. After the message is sent, the value will stay as Yes. To send another message, simply set the value to Yes again. This Property Value is used to trigger the message to be sent.
Server Name | This value is the name of the email server that will send the message. Generally this is the same server name that is provided by an ISP.


Using

Using the Email Sender Device

Typically, the Device is used to send the same type of message to the same recipients. To send a different type of message, or to send to different recipients, a separate Device can be created. A single Device can be reconfigured on the fly allowing the Device to be reused for any number of messages, but for simplicity it is recommended that the following Properties are set initially and not changed.

  • Server Name
  • Message Subject (optional)
  • Message Sender (sometimes optional)
  • Message Recipients

Once the Properties above are setup, they need not be changed when a message is sent. To send a message, simply:

  1. Set the Message Property Value to contain the body of the email message.
  2. Change the Send Message Property Value to Yes. The Device will automatically set this value back to No once the message has been sent.

Setting the Message and the Send Message Properties is usually done from a HouseBot Task. For more flexibility, it can also be set from a HouseBot Script Device. For more information and ideas on using Tasks with the Email Sender Device, see the Using Tasks section.

Once the Send Message Property Value has been set to Yes, the Device will attempt to send the message using the existing Property Values setup in the Device. If the Device encounters an error while attempting to send the message, it will attempt to send the message every minute for the next 10 minutes. If it is unable to send the message after retrying for 10 minutes, it will abandon the effort and log an error to the HouseBot Error log.

Tip:

  • If sending messages to a cell phone over an email gateway, leaving the Message Subject property empty will reduce the size of the message and provide for a better display.


Using Tasks

Using Tasks with the Email Sender Device

The Email Sender Device is usually driven with the aid of a HouseBot Task. For general information on creating HouseBot Tasks, see the main HouseBot help.

Tasks can be used to monitor the system for a particular Property change. When the Property Value changes, the Task can set the Property Values of the Email Sender Device and send the message.

For example, to be notified by email at the office when a phone call is received at home, a condition in the Task would monitor either the Caller ID Info Received or the Phone Call Received Properties of a "Phone Line Status" Device. When the Property Value changes to Yes, the Task can setup the Message Property of the message to indicate the fact that a call has been received. It will then set the Send Message Property Value to Yes to send the message.

Dynamic Message Content

The Message Property Value can be dynamically constructed to allow some flexibility in the message body itself. This can be easily done using a HouseBot Script Device script written in VB. It can also be done using HouseBot substitution strings. See the main HouseBot help for more information on using substitution strings.

Tips:

  • Creating a Mode to indicate whether you are at home or away from home can help control message transmission. If the Task is added to the Mode and the Mode is only active when you are 'away', messages will only be sent when you are out of the house.
  • If forwarding caller ID information, add a condition to the Task that tests the Phone Line Status Last Phone Number Property to NOT EQUAL your cell phone or office number. This will prevent you from receiving messages that you called.
  • An additional Task can be used to enable the 'away' mode if you call your house from your cell or office phone. This is an easy way to enable the Mode remotely, if you forget to enable it before you leave the house.
  • Testing the System Time Time and Day of Week Properties in the Task condition list allows the messages to only be sent during working hours.